Back to feed
20Track

Apache ZooKeeper: Denial of service

Apache Software Foundation Apache ZooKeeper · CVE-2026-100300 ETK-2026-3487
0 news outlets0 CERTs and agencies1 research labs

Assessment: Track

SSVC decision points: exploitation none, automatable yes, technical impact partial, deployment low.

What is it?

Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable. This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.

Evidence

Technical advisories1Detailed write-ups from security research teams

Exploitation

  • Exploit code published (not verified by us)
  • Exploited in the wild (confirmed by a source)
  • Listed as known exploited (CISA KEV)
CVSS
8.7
EPSS
–
First seen
15 h ago
Status
corroborated

All Apache Software Foundation vulnerabilities