Back to feed
20Track

vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE

vllm-project vllm · CVE-2026-115915 ETK-2026-2670 EUVD-2026-110035 GHSA-H3RC-J82P-2C3H
0 news outlets1 CERTs and agencies1 research labs

Assessment: Track

SSVC decision points: exploitation none, automatable no, technical impact total, deployment low.

What is it?

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.

Evidence

Technical advisories1Detailed write-ups from security research teams
Official warnings1National CERTs, government cyber security agencies and the vendor’s own advisories

Exploitation

  • Exploit code published (not verified by us)
  • Exploited in the wild (confirmed by a source)
  • Listed as known exploited (CISA KEV)
CVSS
8.1
EPSS
0.6%
First seen
13 h ago
Status
confirmed

All vllm-project vulnerabilities